Air pump & Valves problem
Welcome to ScoobyIreland.com.
Jolly Green Monster Blackwater Graphics Evo Ireland Pedders Suspension Murray Motorsport -Performance Car Preparation, Parts and Servicing

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    SC7
    SC7 is offline
    Junior Member
    Join Date
    Nov 2012
    Location
    Lurgan
    Posts
    29

    Default Air pump & Valves problem

    Having got my first Scoob last year, a hawkeye. I've had nothing but problems with this Godamn secondary air system. I've had the air pump changed & now the valves in bank 2 are jammed shut! Can anyone point me in the right direction for possibly getting the system taken off, blocking plates & the codes on the ECU mapped out?

  2. Remove Advertisements
    Scooby Ireland
    Advertisements
     

  3. #2
    Senior Member prodrive3384's Avatar
    Join Date
    May 2011
    Location
    Belfast
    Posts
    380

    Default Re: Air pump & Valves problem

    Jgm done mine we just pulled the pump
    out blocked the pipe and he took it of
    the ecu job done and no bother since

  4. #3
    SC7
    SC7 is offline
    Junior Member
    Join Date
    Nov 2012
    Location
    Lurgan
    Posts
    29

    Default Re: Air pump & Valves problem

    Sounds good. Was that jolly green monster? Would he take the pump off & supply the blocking plates aswell

  5. Remove Advertisements
    Scooby Ireland
    Advertisements
     

  6. #4
    Junior Member buckshot's Avatar
    Join Date
    Nov 2009
    Location
    killarney
    Posts
    15

    Default Re: Air pump & Valves problem

    when you say valves in bank 2 are giving trouble think this relates to tumble valves a few codes would help as theese give trouble along with the valves on the secondary air system

  7. #5
    Senior Member prodrive3384's Avatar
    Join Date
    May 2011
    Location
    Belfast
    Posts
    380

    Default Re: Air pump & Valves problem

    Mate I just pulled mine out and blocked the
    pipe and jgm took it of the ecu takes 10 min

  8. #6
    Senior Member prodrive3384's Avatar
    Join Date
    May 2011
    Location
    Belfast
    Posts
    380

    Default Re: Air pump & Valves problem

    Yeh mate jolly green monster

  9. #7
    SC7
    SC7 is offline
    Junior Member
    Join Date
    Nov 2012
    Location
    Lurgan
    Posts
    29

    Default Re: Air pump & Valves problem

    P2441. The valves are completey seized shut. Really would like the whole lot taken off

  10. #8
    Junior Member buckshot's Avatar
    Join Date
    Nov 2009
    Location
    killarney
    Posts
    15

    Default Re: Air pump & Valves problem

    coture auto in dunboyne co meath did mine if you have an sti or wrx there arent any problems 2.0r and 1.5 more diffucult to delete from ecu just buy the blanking plates and fit and delete codes from ecu
    TR Air Pump Delete Kit is use to eliminate the air pump tubes that connect to the cylinder heads on 2006-2008 Subaru Impreza EJ engine. The TR kit seals off the cylinder head where the air injection tubes connected. Used for high performance applications or adapting later cylinder heads to earlier EJ255/EJ257 engines. The plates are machined from T6 aluminum with a titanium anodized finish and all mounting hardware and gaskets are included.

  11. #9
    SC7
    SC7 is offline
    Junior Member
    Join Date
    Nov 2012
    Location
    Lurgan
    Posts
    29

    Default Re: Air pump & Valves problem

    I was onto that fella he told me he couldn't do iit as it was a 2.0R. Turning into a right headache

  12. #10
    Junior Member buckshot's Avatar
    Join Date
    Nov 2009
    Location
    killarney
    Posts
    15

    Default Re: Air pump & Valves problem

    sorry i dont know anyone with programme for 2.0R ecu keep searching someone bound to have one did you try sti tuning

  13. #11
    SC7
    SC7 is offline
    Junior Member
    Join Date
    Nov 2012
    Location
    Lurgan
    Posts
    29

    Default Re: Air pump & Valves problem

    Still haven't got my Scooby back since this problem arose. Now I'm told the codes are being deleted from the Ecu to make the car think the system works fine, Although the system will still be bolted on & NO blanking plates used? Everywhere I've read tells me the system must be physically removed & blanking plates in their place. Can anyone at all shine a light on this?

    F****D OFF & WANT MY SCOOB BACK

  14. #12
    Junior Member
    Join Date
    Aug 2012
    Location
    Ireland
    Posts
    5

    Default Re: Air pump & Valves problem

    @SC7 did you ever get this sorted? If so, what did you do?
    I've the same problem with my car and am considering getting the issue fixed rather than ripped out as it seems hard to find someone who can read an RX ecu. I'm guessing, but I doubt if a dealer would want to remove the valves and the codes from the ecu...?
    I've got a 2.0 rx '07 hawk wagon.

  15. #13
    Member DmcL's Avatar
    Join Date
    Jan 2014
    Location
    Derry
    Age
    34
    Posts
    46

    Default Re: Air pump & Valves problem

    on some of these systems theres a pressure sensor in one of the valves so if fitting blanking plates the one with the sensor in it needs the be cable tied out of the way somewhere and left connected otherwise its meant to make the ECU do strange things.

    i had a run in with SAI system issues like 2 weeks after buying my hawk (and first ever scooby lol). the system is meant to be nothing but problems. some people blank it off and leave the one valve with the sensor in while others just leave the whole lot in and just get it mapped out. apparently the fault codes dont trigger anything in the ECU like limp mode or anything just warm up idle is a bit lower. when i first saw the light on i read the code and reset it which worked for maybe a day, next time it came on and i read/reset it came back on again within like 30 mins so knew something was ****** then. while mine was on the blink i noticed no difference at all bar light on in the dash and lower warm up idle so id be inclined to believe that. as mine was still under the 3 month warranty from when i bought it i ended up sourcing a full second hand SAI system that was working fine when removed (engine was being built to lairy spec and they deleted the SAI system) so i got them to buy that since it was more spares for me and alot less than buying a new valve for one bank so they saved money on the repair also. if the same bank goes again ill just either map it out myself via opensource software (easy to do) or live with the light on till i get the car mapped sometime.

    cant say how hard/easy it would be for a 2.0RX as all i have looked into was regarding the 2.5 WRX like mine.

    EDIT: heres a thread from when i had bother with mine, might help someone.
    http://bbs.scoobynet.com/general-tec...ng-it-off.html
    Last edited by DmcL; 21-01-2014 at 12:06 AM.

  16. #14
    Junior Member
    Join Date
    Aug 2012
    Location
    Ireland
    Posts
    5

    Default Re: Air pump & Valves problem

    DMcL,
    Thanks for the info above.
    I brought my 2.0RX to a dealer who suggested to try fix what was there first. They pulled out the valves and cleaned them. They noticed that there was water in around the wiring/terminals, and asked me if I had steam cleaned the engine at any stage (which I hadn't). They put the whole lot back and turned off the light. All seemed fine for about 15 miles and the light came back on again.
    They rang Subaru Ireland in Dublin and the advice there was to replace the valves and the wiring harness that comes with them.
    I had got a quote from the garage for 1280 euro to replace the valves and I'm still waiting (after several emails\calls) to get a new price to include the replacement of the wiring harness.
    The only reason I need to get this fixed is that the car is now out of NCT (MOT), and it is failing on emissions which I can't get seen to because the air valves could be messing with the o2 sensor etc, so the valves need to be sorted to eliminate them as the source of the problem.
    I also looked into getting the valves mapped out but the RX has a Hitachi ECU which can't be flashed, and I think by the time I'd get that replaced by something open source, I'd be as well to just replace the valves.
    Getting a second hand kit to replace mine is difficult too because i think the WRX version is different to the RX and wont fit, and RXs are not very common down south.
    Does anyone have the name of a few breakers up north that I could contact? I'd appreciate it very much.
    Thanks,
    Adrian.

  17. #15
    Black Hawk Down SCOOBY1929's Avatar
    Join Date
    Apr 2009
    Location
    Bangor
    Posts
    996

    Default Re: Air pump & Valves problem

    Quote Originally Posted by prodrive3384 View Post
    Mate I just pulled mine out and blocked the
    pipe and jgm took it of the ecu takes 10 min
    Do you not need the special plates tho? On my hawk the light came on and I got Brendy on here to pull the code. Secondary air pump so he turned the light off and it has not came back on. That was about a year ago

  18. Page 1 of 2 12 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  

 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49